[#73][알고리즘] 연속합

백준 > 연속합

문제 링크(https://www.acmicpc.net/problem/1912)

문제

n개의 정수로 이루어진 임의의 수열이 주어진다. 우리는 이 중 연속된 몇 개의 숫자를 선택해서 구할 수 있는 합 중 가장 큰 합을 구하려고 한다. 단, 숫자는 한 개 이상 선택해야 한다.
예를 들어서 10, -4, 3, 1, 5, 6, -35, 12, 21, -1 이라는 수열이 주어졌다고 하자. 여기서 정답은 12+21인 33이 정답이 된다.

입력

첫째 줄에 정수 n(1≤n≤100,000)이 주어지고 둘째 줄에는 n개의 정수로 이루어진 수열이 주어진다. 수는 -1,000보다 크거나 같고, 1,000보다 작거나 같은 정수이다.

출력

첫째 줄에 답을 출력한다.

예제 입력 1 

10
10 -4 3 1 5 6 -35 12 21 -1

예제 출력 1 

33

C++풀이
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
 
int main() {
    long long input[100000], test, maxvalue = -9999999;
    vector<long long> plus = {0};
    cin >> test;    //정수 n, 숫자의 개수
    plus.resize(test);
    for (long long i = 0; i < test; i++) {
        //n개의 정수 입력받기
        cin >> input[i];
    }
    
    plus[0= input[0];
    long long tmp = -9999999;
    for (long long i = 1; i < test; i++) {
        plus[i] = max(plus[i - 1+ input[i], input[i]);
        maxvalue = max(plus[i], maxvalue);
    }
    maxvalue = max(plus[0], max(tmp,maxvalue));
    cout << maxvalue << endl;
    return 0;
}
 
cs





  • 점화식찾기
plus[i] = max(plus[i-1] + input[i], input[i])


댓글

가장 많이 본 글